source code can not be use in vs

Mar 30, 2010 at 3:40 AM

hi,i download your latest virsion source code,but the  project can not be generate in visual studio( additionally, visual studio 2008, in .net framework 2.0)

     can you give some  help for this problem?

 thanks

Coordinator
Mar 30, 2010 at 10:04 PM

Please check this link: http://www.surveyproject.info/Forums/tabid/107/forumid/4/threadid/4/scope/posts/threadpage/2/language/en-US/Default.aspx

This might help.

Kind regards
Fwsmaster

Apr 6, 2010 at 10:16 AM

Hi,

I'm sorry to takes you so much trouble. 

the methods you told i had tried,but still can not build the project . when i build any one of the class project it shows some errors.

for example:

when i building the class Votations.NSurvey.BE, the errors message shows can not find then dll path in “E:\****\Reflector\Nsurvey_BE\bin\Debug\Votations.NSurvey.BE.dll”。"

and some else message like do not find  “E:\***\Reflector\Nsurvey_DAL\bin\Debug\Votations.NSurvey.DAL.dll”。 etc.



Kind regards,
Fwsmaster

 

Coordinator
Apr 6, 2010 at 8:11 PM

Hello,

Have you checked the project properties and what VS 2005 does to the Compiling options: set output path to: bin\Debug\? Also check the .csproj files to see how the outputpath's are defined.

Could please ask you other questions at the communitysite? Just visit the Forums at: http://www.surveyproject.info.

Kind regards,
Fwsmaster


Apr 7, 2010 at 8:44 AM

thank you, Fwsmaster
    i check my project properties and see the  Compiling  output path arealy default set in  bin\Debug, but i reset it and save,and now ervery project can build in vs, and web site can running.

thanks.

    and now i found a problem that i can build project in vs by every project .but  when  i choose build the complete  solution,it  just build web application,and the other 7 project's building all be jumped. 

thanks a lot ,the project can running now .

Apr 23, 2010 at 8:35 AM

Hi

Just a quick note to say that I had the same problem exactly. I have both VS2005 and VS2008m on my machine and came up with exactly the same errors. The source code was using the Visual Studio Selector to open it and it chose vs2005. In the end I selected the web_admin project in the trunk and OPEN WITH vs2008. It asked me if I wanted to convert all projects. I answered yes and upgrade to framework 3.5. Everything worked fine first time. No errors in build and none in publish. (Obviously had to change web,.config)

So if you are having problems try just opening with vs2008.

Excellent project by the way and a great help

 

cheers

Paul

Coordinator
Apr 23, 2010 at 10:31 AM
Good advise, thanks for sharing this. Kind regards, Fwsmaster